ANX isn't working with nuclex framework, are both compatible with each other?

Aug 15, 2012 at 8:24 AM

Hello, im trying to use nuclex framework with ANX but it's still returning the AddInLoading Exception when I try to debug the game, I've already put an input system as instructed in documentation, but without success. Hope some help, thanks.

Coordinator
Aug 15, 2012 at 11:59 AM

I think the nuclex framework is referencing xna so this will not work out of the box.

Are you able to provide a sample project which we can debug?

 

Aug 15, 2012 at 2:53 PM
Edited Aug 15, 2012 at 2:54 PM

Hey, thanks for your reply! I have just added the references of both frameworks to a new project and it's return the exception, the project download is below if you want to check it out.

http://www.mediafire.com/?d5nzghoa2r2v3l2

Coordinator
Aug 16, 2012 at 9:04 AM

I will have a look at it tonight...

 

Aug 16, 2012 at 3:31 PM

Okay, I wait for your reply, thanks.

Coordinator
Aug 18, 2012 at 6:51 AM

I have the same error with your code. Which version are you using? The binary one or a source one?

Aug 18, 2012 at 7:36 AM
Edited Aug 18, 2012 at 8:46 AM

I'm using the binary version. I have tried to use the source code one but it's returning the same exception (I've already put a media system in framework folder):

"Couldn't get default MediaSystem because there are no registered MediaSystems available! Make sure you referenced a MediaSystem library in your project or one is laying in your output folder!

Coordinator
Aug 22, 2012 at 11:18 AM

I'm really not sure what the problem is... Please wait some days for the next binary release (or try to build from source), the error handling is improved very much since the last binary version was released.